Hack the Planet

TommyB

Team Bitschubse
17 Mai 2010
2,151
80
48
38
127.0.0.1 ;)
Sprachen
  1. C#
  2. VB.Net
  3. LunaAVR
  4. Assembler
  5. Python
So, RS232 ist verbunden, Konsole läuft :)
Hier mal die Log vom Booten:
Code:
KA Boot 04240806
scu: 11c33303,00000000,00040404,00009f00,1
Status 20200804

Hit to stop :  0
Status 20200804
RCA0 68, RCA1 b3
..
!!!! CRC Error (20200804 20200804)
.reading program.bin
.Error: reading boot sector
.<mmc1>go 208000
<4>(192-96-1)
console [ttyS0] enabled
Mount-cache hash table entries: 512
NET: Registered protocol family 16
bio: create slab <bio-0> at 0
cfg80211: Calling CRDA to update world regulatory domain
NET: Registered protocol family 2
TCP: Hash tables configured (established 1024 bind 1024)
TCP reno registered
ttyS0 at MMIO 0xa0004000 (irq = 1) is a KA2000
msgmni has been set to 58
loop: module loaded
TCP cubic registered
NET: Registered protocol family 17
lib80211: common routines for IEEE802.11 drivers
starting pid 27, tty '/dev/console': '/etc/init.d/rcS'
KeyASIC WifiSD console ...
Sun Jan  1 00:00:00 UTC 2012
ka2000_sdhc: module license 'Proprietary' taints kernel.
Disabling lock debugging due to kernel taint
(0>0)switch_modules
max_blk_size=512, max_blk_count=8, max_req_size=32768
init bomb irq
req irq 40 (1000000)
req irq 43 (40)
req irq 41 (43)
ka_sdhc_drv_init
bw = 22
mmc0: new SDHC card at address b368
mmcblk0: mmc0:b368 CAR 15.0 GiB
 mmcblk0:bootsec @ 2000
 p1
FAT sec 20 sz 3c04 #2 rtdir 7828 csz 10
wsd to sd
wsd to sd
FAT sec 20 sz 3c04 #2 rtdir 7828 csz 10
run autorun.sh
: not foundorun.sh: line 1:
tcpsvd: listening on 0.0.0.0:21, starting
cid = CID:1bd500b71c0000102020434453454a74
Transcend Card
Transcend Card
gen_boa_passwd.sh - USER=admin PASS=admin
rcS done
start boa

-----------------------------------------------
  Production mode-VER. version_150_APR172013_TE.
-----------------------------------------------

sleep disable
[01/Jan/2012:00:00:05 +0000] boa: server version Boa/0.94.14rc21
[01/Jan/2012:00:00:05 +0000] boa: server built Apr 17 2013 at 18:28:52.
[01/Jan/2012:00:00:05 +0000] boa: starting server pid=79, port 80
..setup AP mode start
/usr/bin/auto_off.sh: stop
rmmod: can't unload 'ar6000': unknown symbol in module, or unknown parameter
ifconfig: SIOCGIFFLAGS: No such device
sdio wakeuplo        no wireless extensions.

rm: can't remove '/tmp/iwconfig_maln0.txt': No such file or directory
mmc1: new SDIO card at address 0001

ifconfig: SIOCGIFFLAGS: No such device
AR6000: configuration opcode 7 is only used for RTOS systems, not Linux systems
ath6k/AR6003/hw2.1.1/athwlan.bin firmware will be loaded
AR6K: ** HIF layer does not support scatter requests (17)
wmi_control_rx() : Unknown id 0x101e
Add Filter 0 = 01:00:5e:00:00:01
Keep Filter 0 = 01:00:5e:00:00:01
Keep Filter 0 = 01:00:5e:00:00:01
Keep Filter 0 = 01:00:5e:00:00:01
channel hint set to 0
Limit maximum connection count to 3
/usr/bin/auto_off.sh: start
/usr/bin/kcard_app.sh: start
Auto OFF 0 seconds
kcard_startup: Set call interval 10
WiFi 0 can't less then 60 seconds
KCARD: Notify driver about pid 146
(0>1)KCARD: Log = 0, Diff Disable, Path /tmp/filediff
KCARD: Debounce = 1, WiFi Hide Disable, Skip Disable
KCARD: waitting for sig
dcim c 3 @9838, f:2020 (off 404008)
Folder: 199_WIFI (5f393931 49464957)
user_dir:(5f333231 20505446)(00000000 00000000)
ctrlimg c 1c01ff @1c0b7f8, f:5823 (off b047f8)

misc c 1c0200 @1c0b808
bomb reg2 1c0b808 - 1c0b80d
bomb reg 2020 - 5c24
bomb reg 2020 - 5c24
KCARD: get_Kcard_app cmd 8 - KCARD: KCARD_SIG_NO_IMGS(1>0)
KCARD: kcard_app_act - KCARD: KCARD_SIG_NO_IMGS
dcim c 3 @9838, f:2020 (off 404008)
Folder: 199_WIFI (5f393931 49464957)
user_dir:(5f333231 20505446)(00000000 00000000)
ctrlimg c 1c01ff @1c0b7f8, f:5823 (off b047f8)

misc c 1c0200 @1c0b808
bomb reg2 1c0b808 - 1c0b80d
bomb reg 2020 - 5c24
(0>4)KCARD: waitting for sig
(4>5)(5>0)KCARD: get_Kcard_app cmd 7 - KCARD: KCARD_SIG_UPDATED
KCARD: kcard_app_act - KCARD: KCARD_SIG_UPDATED
KCARD: waitting for sig
FAT sec 20 sz 3c04 #2 rtdir 7828 csz 10
Decompress libcrypto ...
KCARD: waitting for sig
KCARD: Get Pipe FD 3 Read Len 11 [Update list]
KCARD: treecheck
FAT sec 20 sz 3c04 #2 rtdir 7828 csz 10
KCARD: No files changes
KCARD: treecheck done

Please press Enter to activate this console. 
FAT sec 20 sz 3c04 #2 rtdir 7828 csz 10
FAT sec 20 sz 3c04 #2 rtdir 7828 csz 10
Die letzte Zeile wiederholt sich alle paar Minuten. Vermutlich kommts von Windows was versucht auf die Karte zu kommen (die durch den Umbau als nicht formatiert angezeigt wird).
"Skop" und ne 10x LED Leiste liegt auch schon bereit :)
 

TommyB

Team Bitschubse
17 Mai 2010
2,151
80
48
38
127.0.0.1 ;)
Sprachen
  1. C#
  2. VB.Net
  3. LunaAVR
  4. Assembler
  5. Python
And the beat goes on

Ich analysiere grade die Pins (mit meinen beschränkten Mitteln). Die Karte ist eingesteckt, hochgefahren, WLAN ist verbunden (Karte als AP). Serielle Konsole ist offen, sonst nichts.
Entgegen der anderen Webseite habe ich bei der Nummerierung nicht die 13 vergessen, sonst ist sie identisch.
Nummerierung.jpg

Code:
 1 GND
 2 GND
 3 (gemessen stabile 3,3V. Eingang mit Pull-Up?)
 4 -- siehe 3 --
 5 (überwiegend 3,3V, kurze Einbrüche die nur knapp auf meinem Skop zu erkennen sind. Ändern sich nicht bei RS232 und Speicher Zugriff, aber bei WiFi Zugriff. ("Link" Indikator?) *Bild 1 (Zugriff via FTP), *Bild 2 (Idle)
 6 -- siehe 5 --
 7 (überwiegend 3,3V, kurze Einbrüche bei FTP und SD Karten Zugriff. Keine Regung bei RS232. Vielleicht so eine Art HDD Lampe? Oder sogar das Clock Signal für den Flash?)
 8 VDD (3,3V)
 9 (gemessen stabile 1,44V, konnte keine Signaländerung herstellen durch Zugriffe)
10 RS232 RxD (3,3V Pegel)
11 (Mysteriöses Rechteck-Signal. 200 & 784Hz abwechselnd. Keine Änderung bei jeglichen Zugriffen) *Video 1
12 -- wie 11, jedoch inventiert --
13 RS232 TxD (3,3V Pegel)
14 (Überwiegend 3,3V. Irgend etwas ist da. Ich seh leichte Andeutungen von Sägezähnen. Das Signal ist zu schnell für mein Skop. Keine Änderung beim Zugriff.)
15 (Signal mit irgendwas um die 150Hz, ebenfalls keine Änderung *Bild 3)
Alles in Klammern sind reine Vermutung oder geraten oder wie man es nennen möchte. Sobald ich mehr weiß werde ich diesen Post hier ändern lassen.
Scheinbar einige Clock Ausgänge, aber ich vermute mal auch der ein oder andere GPIO. Let's check :)
Aber allein schon dass RS232 gut läuft reicht ja schon fast.

Hier die Bilder:
1) 1.png 2) 2.png 3) 3.png

Hier das Video:
[video=youtube_share;p3Lvg9ZmcS8]http://youtu.be/p3Lvg9ZmcS8[/video]

Edit: Auch noch erwähnenswert:
Die Test-Pins sind kaum fähig auch nur eine LED anzusteuern. Will man also was damit machen (sofern das möglich ist, weitere Tests stehen ja noch aus) muss man halt Bus Treiber, Transistoren oder ähnliches nutzen.

Edit 2: Whohooo, der 500. Post ^^
 

Über uns

  • Makerconnect ist ein Forum, welches wir ausschließlich für einen Gedankenaustausch und als Diskussionsplattform für Interessierte bereitstellen, welche sich privat, durch das Studium oder beruflich mit Mikrocontroller- und Kleinstrechnersystemen beschäftigen wollen oder müssen ;-)
  • Dirk
  • Du bist noch kein Mitglied in unserer freundlichen Community? Werde Teil von uns und registriere dich in unserem Forum.
  •  Registriere dich

User Menu

 Kaffeezeit

  • Wir arbeiten hart daran sicherzustellen, dass unser Forum permanent online und schnell erreichbar ist, unsere Forensoftware auf dem aktuellsten Stand ist und der Server regelmäßig gewartet wird. Auch die Themen Datensicherheit und Datenschutz sind uns wichtig und hier sind wir auch ständig aktiv. Alles in allem, sorgen wir uns darum, dass alles Drumherum stimmt :-)

    Dir gefällt das Forum und unsere Arbeit und du möchtest uns unterstützen? Unterstütze uns durch deine Premium-Mitgliedschaft!
    Wir freuen uns auch über eine Spende für unsere Kaffeekasse :-)
    Vielen Dank! :ciao:


     Spende uns! (Paypal)